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How to Perform a Two-Way (Within-Between) ANOVA in SPSS
When to use a two-way, within-between, ANOVA
A two-way ANOVA, also called a two factor ANOVA, can be used when there are two independent variables (factors) influencing one dependent variable.  In the example below, one factor is method of training, and the second factor is time.  Training method is the “between” factor, because we are looking at differences between groups using different training.  Time is the “within” factor, because we are measuring each group twice (pre-test and post-test).  Therefore, we are also interested in the difference within each group over time.
Why ANOVA and not T-test?

1. Comparing three groups using t-tests would require that 3 t-tests be conducted.  Group 1 vs. Group 2, Group 1 vs. Group 3, and Group 2 vs. Group 3.  This increases the chances of making a type I error.  Only a single ANOVA is required to determine if there are differences between multiple groups.
2. The t-test does not make use of all of the available information from which the samples were drawn.  For example, in a comparison of Group 1 vs. Group 2, the information from Group 3 is neglected.  An ANOVA makes use of the entire data set.

3. It is much easier to perform a single ANOVA then it is to perform multiple t-tests.  This is especially true when a computer and statistical software program are used.
The Theory in Brief

Like the t-test, the ANOVA calculates the ratio of the actual difference to the difference expected due to chance alone.  This ratio is called the F ratio and it can be compared to an F distribution, in the same manner as a t ratio is compared to a t distribution.  For an F ratio, the actual difference is the variance between groups, and the expected difference is the variance within groups.  Please read the ANOVA handout for more information.
Let’s Roll
Set-up your data so that one column categorizes your data into groups and a separate column is assigned for each measurement time.  For this example, three groups (N=20) of track athletes participated in a study to ascertain the effects of traditional strength training (Squats) and power training (Cleans).  The Squats group underwent 12 weeks of strength training, the Cleans group underwent 12 weeks of power training, and a Control group did nothing.  Vertical jump was measured for each group before (Pre Test) and at the conclusion (Post Test) of the training.  Based on this information, there is one column (Group) that indicates which of the 3 groups the data belongs to.  There are also 2 columns of actual data, one for the Pre Test and one for the Post Test.  This is shown in Figure 1.  At this point, you should assign “values” to the numbers in the Group column.  For example, “1 = Control”, “2 = Squat”, “3 = Cleans”.  Refer to the handout How to Perform a One-Way ANOVA in SPSS.
Figure 1: Data View
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To perform the Within-Between ANOVA, select Analyze -> General Linear Model -> Repeated Measures as shown in Figure 2.
Figure 2: Starting the Repeated Measures ANOVA
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Select a name for your within-subject factor.  The default is “factor1” but you should change it to something that has relevance.  For our example, change it to “test”.  “Levels” is the number of times the measure was repeated.  In our example, vertical jump was measured 2 times.  You should then select the “Add” button (See Figure 3). 
Figure 3: Selecting the Within-Subject Factor
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After selecting “Add”, the window should look like Figure 4.  At this point you could add another within-subject factor if one existed.  “Add” a Measure Name, and hit “Define”.
Figure 4: Measure Name
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After you click “Define”, the window shown in Figure 5 should appear.   At this point, the within-subject factors, and the between-subjects factors should be assigned to specific columns of data.  Since the same subjects undergo a Pre Test and a Post Test, this is the within factor.  It shows changes within a subject.  Different subjects were assigned to the three groups (Control, Squat, and Cleans), therefore Group is the between factor.  It shows changes that occur between different subjects due to training.  See Figure 5 for clarification on Factor assignment.
Figure 5: The Repeated Measures Window
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After associating the factors with the appropriate columns of data, select the “Contrasts” button and the window shown in Figure 6 will appear.  This window provides features for contrasting the levels of a certain factor.  This was done with the “Beer Consumption – Golf Performance” data.  However, for this example and with most Within-Between designs, contrasting levels of a certain factor is not useful.  This is because all levels of the other factors are collapsed together.  For example, the contrast window would allow us to compare the difference between the Pre Test and Post Test by selecting “test(Repeated)”.  However, this setting would compare all groups at Pre Test to all groups at Post Test.  This is not a useful measure as we would expect each group to show different changes between Pre and Post.  Averaging across all groups may mask these individual group changes.  Therefore do NOT run and/or analyze any contrasts.
Figure 6: Repeated Measures Contrast Window
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From the “Repeated Measures” window, select “Plots” and Figure 7 should appear.  Select “test” and place it in the “Horizontal Axis” box.  Select “Group” and place it in the “Separate Lines” box.  Following this, the “Add” button will become selectable.  Select “Add” to bring “test*Group” into the “Plots” box at the bottom of the window.  Then hit “Continue”.

Figure 7: Plots Window
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From the “Repeated Measures” window, select “Options” and Figure 8 should appear.  Take the necessary steps to display the means for the “Group*test” marginal means.  This will produce a table which will display a mean for each combination of factor levels.  This information will be redundant with the Descriptive Statistics.  For example, Control/Pre, Control/Post; Squat/Pre, Squat/Post; Cleans/Pre, Cleans/Post.  Check off “Descriptive statistics” and “Estimates of effect size”.  Then hit “Continue”.

Figure 8: Options Window
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From the “Repeated Measures” window, select “OK” to run the Within-Between ANOVA.  The following should help you analyze your data.

The first important, and non-obvious, chart in the SPSS output is the test for sphericity.  A repeated measures ANOVA must meet the assumption of sphericity.  Sphericity requires that the repeated measures demonstrate homogeneity of variance (each group of data has similar variance) and homogeneity of covariance (the correlation of each repeated measure with the dependent variable is similar).  In this case, there is only a Pre and Post test, so sphericity is not something that we have to worry about (we would if there was also a Mid test).
Figure 9: Mauchly’s Test of Spericity
Mauchly's Test of Sphericity

       Measure: vjump 

	Within Subjects Effect
	Mauchly's W
	Approx. Chi-Square
	df
	Sig.
	Epsilon(a)

	 
	 
	 
	 
	 
	Greenhouse-Geisser
	Huynh-Feldt
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	1.000
	.000
	0
	.
	1.000
	1.000
	1.000


Figure 10 displays the main results of the Within-Between ANOVA.  The analysis of the main effect of “test” is significant.  This means that there is a significant difference between the Pre and Post tests when all groups are averaged together.  This is not very helpful, because we are interested in knowing how the Squats, Cleans and Control groups improved relative to each other?  The test*Group analysis is the most important part of the entire Within-Between ANOVA output.  As shown below, the interaction between test and Group was significant.  Basically, this means that the groups had significantly different changes from Pre to Post.  It could be that there was no change for the Control and Squat group, but there was an increase for the Cleans group.  Another possibility could be that the Squat group actually decreased in jump height, while the Cleans and Control remained unchanged.  Analyzing the plot in Figure 13 and using common sense will give us the specific answer.
Figure 10: Tests of Within-Subjects Effects
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Figure 11 compares each trial with the adjacent trials.  With a Pre Test/Post Test design, as in this example, the table provides redundant information.  Since there are only 2 measurement times to compare the results are identical to the Within-Subjects Effects shown in Figure 10.
Figure 11: Tests of Within-Subjects Contrasts
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Figure 12 shows the test of Between-Subjects Effects.  In our case, this tests if there are significant differences between the 3 groups.  However, this test combines the Pre Test and Post Test data for all groups.  Therefore, for our example, this is not a useful test.  For example, if the Control group averaged 80 cm on both the Pre and Post test, while the Cleans group scored 76 and 84 cm on the Pre and Post tests respectively, then the improvements of the Cleans group would not show up in the test.  We can see in Figure 12, that when the Pre and Post tests are combined the groups are not significantly different (p = .601). 
Figure 12: Tests of Within-Subjects Effects
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Figure 13 shows the plot of the mean scores for each combination of factor level.  Put another way, it shows how each group performed on the Pre Test and Post Test with each line representing a group.  From this graph it is clear that one should recommend performing Cleans instead of Squats to improve vertical jump performance.  However, it is not clear where the statistical significant differences lie with respect to the rate of improvement.  We know that some groups improved more than other due to the significant interaction, but which ones?
Figure 13: Plot of Means
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Did the Squat group show a significant improvement relative to Control?  Did the Cleans group improve significantly more than the Squats group?  These were questions we wanted answered right from the beginning of the study, before any data was collected or analyzed.  As such, the methods used to answer these questions are referred to as planned comparisons.  Referring to Figure 13, we want to compare the slopes of the lines.  Are any of the slopes significantly different from any of the others?  Notice that the slope of the lines can be determined by subtracting the Pre-test from the Post-test to find the change.  Therefore, we need a statistical test that can compare the change scores across groups and further tell us where the differences lie.  Fortunately, we have already learned how to perform an analysis that does just what we want; a one-way between factor ANOVA followed by Scheffe post hoc tests.

To conduct the one-way ANOVA, we must first generate another variable which represents the change scores from Pre-test to Post-test.  Select Transform -> Compute as shown in Figure 14.

Figure 14: Generate a new ‘Post – Pre’ variable
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The Compute Variable window will then appear.  Type Change as the name for the Target Variable.  This will be the name of the new dependent variable.  Highlight Post_test by clicking on it, then hit the arrow button to bring it into the Numeric Expression: box.  Hit the subtract button, and then bring in Pre-test.  Once your screen looks like Figure 15, hit OK.  A new column labeled Change should now be located to the right of Post_test in the Data View. 
Figure 15: Generate a new ‘Post – Pre’ variable using Compute Variable
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From this point, you can follow the instructions in the handout “How to Perform a One-Way ANOVA in SPSS”.  Change will be the Dependent Variable.  Figure 16 shows all the important output to determine which groups are significantly different with respect to the interaction.  As you can see, the F-value and p-value for this ANOVA are the same as those found for the interaction term in Figure 11 above.  The Scheffe test shows that the only significant difference is between the Cleans and the Control group.  So statistically speaking, the improvement the Cleans group showed was not significant in comparison to the improvement the Squat group showed.
Figure 16: Output from ANOVA used as a Post-Hoc for the Interaction
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We now know which groups improvement significantly relative to the other groups, but we don’t know if the subjects within any particular group improved significantly from pre-test to post test.  For example, it can be seen from the positive slope that the Squat group did improve from the pre-test to post-test; however, we do not know if the change was significant.
Did the Squats group show significant improvement from Pre to Post test?  The output from the Within-Between ANOVA does not answer this specific question.  A valid and simple way of answering this question is to perform a paired sample test using only the Squat Pre and Squat Post data.  To accomplish this with our current data setup, some additional steps need to be taken.

From the Data View, select Data -> Select Cases, as shown in Figure 17.  
Figure 17: Selecting Data from a single Group
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This feature allows you to force SPSS to perform any future calculations only on the data you select.  For our example we want to isolate the Squat group.  As shown in Figure 18, select “If condition”, hit the “If” button, and set “Group = 2”.  This will create a “filter” column that indicates to SPSS which data to run future calculations on.  Then run a paired t-test and analyze the data.  To run the t test, select Analyze -> Compare Means -> Paired-Samples T Test.  See “How to perform a dependent t-test in SPSS” for more information.
Figure 18: The “If condition”
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